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1 emDrive Configurator tool (SW version 2.0 or higher) 

emDrive Configurator is CAN open tool developed by Emsiso. It was primarily designed for 

usage with Emsiso products, but it can be used with any third-party device supporting CAN 

open protocol. emDrive Configurator also has some additional features specific only for Emsiso 

products (for example unique oscilloscope feature) that will not work on third-party devices. If 

emDrive Configurator is used with third-party CAN interface specific features (outside CAN 

open protocol) will also not work (for example oscilloscope feature will not work). 

1.1 Installation 

Download emDrive Configurator from web page and follow installation information (in case of 

security warning message proceed by selecting Run/Install option). After application first run 

unselect “Always ask before opening this file”. Licence Management window will appear if valid 

licence was not found (follow application instructions for getting and applying licence). In case 

of upgrade from version less than 2.0 to version 2.0 or higher notification window regarding 

old licence type will appear. It is advised to contact us for new licence type. Without new licence 

type emDrive Configurator will work as before, but some new features may not be available. 

  
Fig. 1: emDrive Configurator application installation security warning 

 

 
Fig. 2: emDrive Configurator application run security warning 

 

  

http://www.emsiso.com/
http://www.emdrive-mobility.com/


    

 emDrive Configuration tool User Manual 2I P a g e   
 
 

 www.emsiso.com 
www.emdrive-mobility.com 

Copyright © Emsiso d.o.o.  
All rights reserved. 

Rev. 2.0.  

 

1.2 emDrive Configurator user interface 

emDrive Configurator is divided to menu bar, status panel, main window, docked window and 

status bar. All main and docked windows can be shown or hidden in View menu and they can 

be freely docked anywhere or even floated separately (double mouse click or left mouse click 

on window name).  

 
 

Fig. 3: emDrive Configurator user interface 

1.2.1 Menu bar 

Table 1: emDrive Configurator Menu bar options 

Menu name Menu option Short description 

File Save project Save current project 

Load project Load project 

Save EDS Save Electronic Data Sheet 

Save DCF Save Device Configuration File 

Load DCF Load Device Configuration File 

Exit Exit/close emDrive Configurator 

View Start page Main window enable/disable page. 

SDO browser Main window enable/disable page 

Live chart Main window enable/disable page 

Oscilloscope Main window enable/disable page 

Watch Docked window enable/disable page 

Sliders Docked window enable/disable page 

EMCY messages Docked window enable/disable page 

Network Connection Connection menu. See pictures following this table 

Nodes Nodes menu. See pictures following this table 

Device Firmware update Firmware update. See pictures following this table 

Save parameters (Ctrl + S) Save parameters (on emDrive device) 

Set parameters to default (Ctrl + D) Set parameters to default (on emDrive device) 

Script Edit/running scripts. See pictures following this table 

Help View help (Ctrl + F1) Help 

About emDrive Configurator About information 

 

 

  

MAIN WINDOW 
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STATUS BAR 

MENU BAR 
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File menu 

Save/Load project. emDrive Configurator allows user to save/load project file for later use on 

PC drive. Project file includes Network description (EDS files), Watch, Shortcuts, Sliders and 

other user settings. 

 

Save EDS. Electronic Data Sheet (EDS) is standard CANopen file that contains list of all objects 

supported by device with their parameters. With this command user can download EDS file 

directly from emDrive device. Downloaded EDS file is standard text file with .eds extension. 

 

Save/Load DCF. Device Configuration File (DCF) is standard CANopen file that contains list of 

objects with values in moment that was saved. DCF can be saved and loaded with any CANopen 

software that supports this functionality. To save or load DCF file make sure that connection to 

the device is working and communication port is opened with right Node-ID selected. Select 

Save DCF or Load DCF from menu and browse computer for file path. 

 

View menu 

Menu options in View are described in Main and Docked window chapter. 

 

Network menu 

Connection window. To obtain bitrate of the USB-CAN interface click Read CAN card bitrate. To 

select different CAN bitrate, use Change CAN bitrate dropdown menu and click Apply to confirm 

new setting. Click Read CAN card protocol to obtain information about selected protocol. To 

select different CAN protocol, use Set CAN protocol dropdown menu and click Apply to confirm 

new setting (if dropdown menu is disabled licence for this option is not installed). In Manual 

connecting mode select from dropdown menu COM Port (use Refresh button to update list of 

available communication ports). For opening/closing communication port use Open and Close 

buttons. In Automatic connecting mode application will automatically select and open 

connection based on device name (for Emsiso USB-CAN interface correct string is already set 

by default). If Show connection menu checkbox is selected additional connection menu will be 

shown under menu bar for quick access to communication setting control. If Check connection 

is selected emDrive Configurator will send periodically CAN requests to device to verify if device 

is still connected. If Read on click is selected, reading object values in SDO browser is done by 

single click on SDO browser object structure (if read on click is not selected reading object value 

is done by additional click on read button). Addition information about communication is visible 

in Status of command queue. Waiting queue is cleared with click on Clear buffer button. 

http://www.emsiso.com/
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Fig. 4: emDrive Configurator Menu bar -> Network -> Connection 

 

 
Fig. 5: emDrive Configurator Menu bar -> Network -> Connection (show connection menu) 

 

Nodes window allows scan network and loading existing EDS file from computer or 

downloading it from device. Start scan will start scan for available network nodes. This step can 

be skipped if ID number of devices is already known (in this case Node-ID number is entered in 

table). Scanning process can also be stopped when Node reaches the ID number of connected 

devices. Normally default emDrive device node ID is 1. Refresh button will check only status of 

Node-IDs that are already in table. Download button is used to get EDS information from device. 

If EDS file of device is already available loading file is possible instead of downloading file again. 

Select “…” and browse for EDS file. After loading EDS file SDO browser is automatically updated. 

 

 
Fig. 6: emDrive Configurator Menu bar -> Network -> Nodes 
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Device menu 

Firmware update of device is possible in this window. Check Node ID value of emDrive device 

value before starting firmware update procedure (if needed change Node ID in Status panel 

under General Node-ID). Browse for Firmware file and click Update button. Follow instruction 

messages that appear during procedure.  

 

  
Fig. 7: emDrive Configurator Menu bar -> Device -> Firmware update 

 

 
Fig. 8: emDrive Configurator Menu bar -> Device -> Firmware update (Save DFC file) 

 

 
Fig. 9: emDrive Configurator Menu bar -> Device -> Firmware update (Uploading progress) 
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Fig. 10: emDrive Configurator Menu bar -> Device -> Firmware update (Load DFC file) 

 

 
Fig. 11: emDrive Configurator Menu bar -> Device -> Firmware update (end message) 

 

Save parameters (Ctrl + S). Save parameter values to device internal memory (EEPROM). 

 

Set parameters to default (Ctrl + D). Command will Reset all parameters to default values. 

 

Script window allows Run or Edit created scripts. Script usage is only for advanced users (usually 

Emsiso provides script file and customer uses only Browse and Run script). 

 
Fig. 12: emDrive Configurator Menu bar -> Device -> Script 
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1.2.2 Status panel 

Status panel is divided to General, NMT commands, Shortcuts, Sync and Status section. 

 
Fig. 13: emDrive Configurator Status panel 

 

General section. Node-ID of device that we want to control/monitor is selected. With Get 

Device-ID button unique identification number of connected device is obtained. 

 
Fig. 14: emDrive Configurator Status panel (General) 

 

NMT commands (Network Management) section allow user to set state of one or all nodes on 

CAN network. Stopped disables transmit or receive any messages except node guarding or 

heartbeat messages as well NMT messages. Comm Reset will reset CAN communication. Reset 

will reset controller. Preoperational state is mainly used for making changes of CAN node 

parameters (it disables DSP402 state machine so that parameters can be safely changed. In this 

state power stage of the controller is disabled). Putting CAN node device into Operational will 

start DSP402 state machine and enable PDO communication. Operational state is mandatory 

condition to run motor. 

 
Fig. 15: emDrive Configurator Status panel (NMT commands) 

 

Shortcuts section is part of status panel and is designed to allow user easy and fast access to six 

predefined object writes. Shortcuts offers user six ready to be customized buttons. Shortcuts 

are also triggered with keyboard hotkeys F1 to F6. To Add object to shortcut, browse for object 

in SDO Browser, right click object, chose Add to shortcut menu and select shortcut number. To 

edit shortcut right click on shortcut, click Edit, edit Value and Shortcut text, click Apply. 

  
Fig. 16: emDrive Configurator Status panel (Shortcuts and edit shortcut) 
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Sync section. Sync is used to produce Sync messages with Emsiso USB-CAN interface. 

 
Fig. 17: emDrive Configurator Status panel (Sync) 

 

 
NOTE: To use Sync feature it is necessary to use Emsiso USB-CAN interface! Sync time is not guaranteed! 

 

Status shows status of connection between PC and USB-CAN interface and status of connection 

between USB-CAN interface and emDrive device with green/red colored line. 

 
Fig. 18: emDrive Configurator Status panel (Status) 

 

1.2.3 Main Window 

In Main Window Start page, SDO browser, Live Charts and Oscilloscope are visible if enabled in 

View menu. 

 

Start Page shows list of saved recent projects and Open Other Projects button. 

  
Fig. 19: emDrive Configurator Main Window (Start Page) 

 

SDO Browser. To open this window chose SDO Browser from View menu. SDO Browser is used 

to Read or Write value to any object that is supported in device dictionary. SDO Browser is also 

used to Add objects to Watch, Oscilloscope, Shortcuts and Slider (with right click on object). 

Search and select wanted object in SDO browser by scrolling or use search dialog box to enter 

object text string. Representation of object read and write value can be hexadecimal or decimal 

(right mouse click inside object Value box). 

http://www.emsiso.com/
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Fig. 20: emDrive Configurator Main Window (SDO browser) 

 

1.2.4 Main window - Live Charts 

To open Live Chart window chose Live Chart from View menu. It is possible to select up to four 

charts (with checkbox) and on every chart one or more parameters can be shown. Parameters 

are added to chart in watch window (described in docked window). Any object in watch can be 

added to chart. In watch window select chart number and object will be available in Live Chart 

at selected chart number. In Live charts Main controls, Enable charts and Automatic scaling 

section are available. 

 
Fig. 21: emDrive Configurator Main Window (Live Charts controls) 

 

In Live charts Main controls section Run/Pause, Clear history, Refresh rate, Export and Import 

data are available. To show/pause drawing logged data of selected object click Run/Pause 

button in Live Chart. Clear history button will clear currently logged object data (data collecting 

will start from beginning). Refresh rate setting is used to optimize chart response and overall 

application performance (for example if large number of data is expected in chart then value 

for refresh rate can be adjusted to improve performance). Export data will save all data 

monitored in watch window to .csv file. Import data will load all data stored in .csv file. 

 

 

NOTE: Run/pause button is only for running/pausing Live Chart. Run/pause button will not stop collecting data. 
To stop collecting data unselect Enable checkbox in watch window or remove object from watch window. 

 

NOTE: Importing data from file will clear live charts and watch window. Watch Enable checkbox is unselected. 
To compare live and imported values add SDO objects into watch window after importing data. 

 

In Live charts Enable charts section Chart 1 to Chart 4 checkbox are available. 

In Live charts Automatic scaling section Autoscale Y, Slide X and value for slide X are available. 

With selected Autoscale Y checkbox Y-axis will automatically adjust to values in chart. For X-axis 

scaling enable Slide X and set window period that is shown for X-axis. Live charts chart drawing 

area. With left mouse and selection or mouse scroll inside graph window zooming is done (use 

http://www.emsiso.com/
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Pause button before using zoom). Other graph options are available with right mouse click 

inside graph window.  

 
Fig. 22: emDrive Configurator Main Window (Live Charts) 

 

1.2.5 Main window - Oscilloscope 

Oscilloscope is Emsiso special functionality for advanced analysis of device behavior. With 

oscilloscope user can set device to record any object values in real time and save them to 

internal RAM or EEPROM memory. For later analyze export/import of CSV file is possible. 

Oscilloscope window is divided to Chart area, Settings, Trigger and Channels section.  

 
Fig. 23: emDrive Configurator Main Window (Oscilloscope) 

 

Parameters for oscilloscope are selected and added in SDO browser. After parameter is added 

to oscilloscope it needs to be configurated. Available options for configuration for every 

oscilloscope section are described below. In general, basic steps that are needed to use 

oscilloscope are: add object/parameter to oscilloscope, select Chart no., add and set trigger 

settings, set settings and at the end click WriteConf. After basic settings use Run/Stop button 

and Read Data button. 

 

 

CHANNELS 

 
TRIGGER 

 

SETTINGS 

CHART AREA 
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Chart area. Recording of parameters is done with Run and Stop button. Continue button allows 

continuing recording parameters without clearing previous recorded data. Oscilloscope status 

shows current status of oscilloscope. It is possible to select up to four charts (with checkbox) 

and on every chart one or more parameters can be shown. Read data reads and shows recorded 

data in chart (reading progress is shown in Read progress). With left mouse and selection or 

mouse scroll inside chart window zooming is done. Other chart options are available with right 

mouse click inside chart window. 

 

Settings section. Select recording target Memory (RAM, FLASH) from dropdown menu and set 

Sample rate or Sample time (Sample rate and sample time values are connected. Changing one 

will change other). Store results to flash will record data to controller flash memory. Recorded 

information in controller flash memory is permanent and can be readed if controller was turned 

off in meantime. Once all Oscilloscope settings are done write setting configuration with Write 

configuration (Settings, Trigger and Channels list are saved to controller). With Read 

configuration existing oscilloscope configuration is loaded from device and shown. Export .csv 

file will export data to CSV file that can be later loaded with Import .csv file. In Additional settings 

window Oscilloscope frequency can be set Automatic or Manual. In manual mode value can be 

manually entered. Default values are set with emDrive and BMS button. In section Osciloscope 

unit select between Samples or Time setting. If parameters have been changed save changes 

with Save settings button. 

  
Fig. 24: emDrive Configurator Main Window (Oscilloscope additional settings) 

 

 

NOTE: Read configuration and Import .csv file will not load Chart no. numbers. After Read configuration or 
Import .csv file select Chart no. numbers manually. 

 

Trigger section. To set trigger Source right click on parameter in Channels section and chose Set 

trigger. Different trigger options are selected with trigger Mode dropdown menu. Trigger Level 

is decimal value used for trigger condition. Pretrigger % value represent percentage of data that 

was measured and shown in oscilloscope chart before trigger condition was fulfilled. For 

Pretrigger % decimal values from 0 to 99 are valid. 

 

Channels section. Search in SDO browser for wanted objects and add them to Oscilloscope with 

right mouse click in SDO browser (select Add to oscilloscope). After objects for oscilloscope have 

been added to Oscilloscope select Chart no. in channel section. With right mouse click and 

selecting Remove or Remove all objects are removed from channel list. With right mouse click 

and selecting Set trigger object is added to trigger section where more options for trigger are 

available. 
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1.2.6 Docked Window 

In Docked Window are visible Watch, Sliders and EMCY messages (if enabled in View). In docked 

window also Firmware update window will appear (if selected in Device menu). Firmware 

update is described under Device menu. 

 

Watch window is used to periodically read multiple values from device. If Enable checkbox is 

selected watch window readings will periodically refresh. Period of reading values is set in ms. 

With Read all button manual reading of all object/parameters in watch is done. Direct value 

write for objects that are write type is done by entering new value to value column. Watch 

window is also used to add/remove objects in Live Charts (in watch window set Chart value 

from 1 to 4 to add object or empty for removing object). Use right mouse click to select 

hexadecimal or decimal representation of object value. Other watch options are available with 

right mouse click inside chart window. 

 
Fig. 25: emDrive Configurator Docked Window (Watch) 

 

 

NOTE: If Enable checkbox is checked object data will be logged until checkbox is unselect. To clear previous data 
use right mouse and select Clear history (will clear only selected objects) or Clear history for all. 

 

Sliders. To see Sliders select Sliders from View menu. Object/parameter is added to slider in 

SDO browser (with right click on object). It is possible to add only objects that are write type. If 

needed set maximum and minimum value (value must be inside object absolute limits). If Sync 

(1s) is enabled reading of object value will be done every second. To change value, move Slider 

up/down with mouse or manually type value in Current value box. 

 

 
Fig. 26: emDrive Configurator Docked Window (Sliders) 
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EMCY messages window is used to periodically read EMCY messages from device. EMCY 

messages are CANopen emergency messages. If Enable checkbox is selected EMCY window 

readings will periodically refresh. Period of reading values is set in ms. Clear history button will 

clear EMCY messages window. EMCY message information has Time, Node-ID, Error code and 

Description. For detailed error description read device user manual and chapter with errors and 

warnings. 

 
Fig. 27: emDrive Configurator Status panel (Error log window) 

 

 

NOTE: EMCY message time is application (computer) time of reading EMCY and not the time when error appeared 
on device. 

 

1.2.7 Status bar 

Status bar shows basic information about connection status and errors related to 

communication or device status (for example connection status and EMCY message reception). 

 
Fig. 28: emDrive Configurator Status bar 
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1.3 First time use of emDrive Configurator and SDO Browser 

Check if device, USB-CAN interface, cables, power supply are correctly connected and working. 

Run emDrive Configurator application. At first run application will ask for licence (follow 

application instructions for getting licence). After licence was applied emDrive Configurator is 

ready for usage. For using emDrive Configurator with emDrive devices correct connection 

setting are needed and get device information. Procedure is described in steps below.  

Document assumes that reader has an understanding of CAN protocol and its usage. CAN open 

device parameters are described by its Object Dictionary. emDrive Configurator SDO Browser 

is used to Read or Write values off any object that is in device dictionary. An Electronic Data 

Sheet (EDS) is a text file representing the Object Dictionary structure which doesn’t contain 

data values. Device Configuration File (DCF) is a text file similar to an EDS except that it contains 

data values as well as the Object Dictionary structure.  

 

NOTE: It is assumed that everything is correctly connected and working. It is also assumed that emDrive 
Configurator is used with emDrive USB-CAN interface. 

 

NOTE: It is assumed that reader is familiar with CAN open protocol. For this reason, only basic information 
needed for reading and using this user manual is provided. 

 

NOTE: For future connections to same device this procedure/steps can be skipped if project was already saved 
(menu File->Save project). In such cases only Load project is needed (menu File->Load project)  

 

Step 1: Select menu Network -> Connection -> select Automatic connecting 

 
Fig. 29: emDrive Configurator connection example 

 

 
NOTE: For manual connection read emDrive Configuration user manual chapter. 
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Step 2: Select menu Network -> Nodes 

 
Fig. 30: emDrive Configurator Scan network example 

 

 

NOTE: If ID number of devices is known, ID can be entered manually and device status is just checked with 
Refresh. 

 

After these steps device dictionary structure is visible in SDO browser. Meaning and usage of 

individual parameters is not described in this user manual. 
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